Resin restarts with "exit reason: HEALTH (exit code=9)".

 
[Symptom]
The message like below is output and Resin restarts with "exit reason: HEALTH (exit code=9)".

WarningService: Shutdown: caucho.database.corrupt[****/resin-data/app-0/distcache/data.db] Table[data:6,****\resin-data\app-0\distcache\data.db]: inode block 1ab8 has invalid block code (0) expected (2)

[Occurrence condition]
The "caucho.database.corrupt" message is output when an inconsistency occurs in the internal database of Resin.

[Cause]
This occurs in the following cases.
 ・When java process or machine is under heavy load status.
 ・When high volumes of session data are stored.
 
[Handling method]
In case of recurrence, please consider the following method. 

 Delete "<%RESIN_HOME%>/resin-data/app-0/distcache"
  Delete "<%RESIN_HOME%>/resin-data/app-0/distcache" directory on the event occurrence server and start Resin. 

In order to prevent similar events from occurring in the future, please consider the following methods.
◆Disable session_store of resin.properties(false)
 A load of the writing of session information is reduced by setting the following.   <Example setting of resin.properties> 
  session_store : false
 
  However, session failover will not be operated if session_store is disabled. 
   
  If you want to disable session_store and take advantage of the use session failover, please consider using the session management module. 

  ■Session Management Module
   https://dev.intra-mart.jp/share_im_session_store/

◆Update to the latest version of Resin 

  The internal database of Resin has been improved with each version, so it is recommended to use a higher version.
  For updates to higher versions, please refer to the FAQ below. 

  ■Is it possible to use a higher version of Resin that is not included in the product support?
   https://product.intra-mart.support/hc/ja/articles/360019552274 (Japanese)

-- Target ------------------------------------------------------------------
iAP/Accel Platform/All Updates
------------------------------------------------------------------------------

FAQID:625
Was this article helpful?
0 out of 0 found this helpful
Powered by Zendesk