What is your measures for intra-mart products on a hands-up related to the vulnerability of Apache Commons FileUpload and Apache Tomcat?

 
The corresponding patch related to the published contents in the following URL page was released as the countermeasures for intra-mart products on a hands-up related to the vulnerability of Apache Commons FileUpload and Apache Tomcat.
http://www.jpcert.or.jp/at/2014/at140007.html (Japanese)

Details are as follows.
It is reported that target versions are from 1.0 to 1.3. We, however, confirmed that the vulnerability is shown only in between 1.2.2 and 1.2 and not in the earlier versions.
The relationship of iWP/iAP and Commons Fileupload versions is as follows (some changes depending on whether or not the patch is applied).
iAP 8.0.x -> Commons-Fileupload 1.2 / 1.2.2
iWP 7.2 ->  Commons-Fileupload 1.2.2 / 1.2
iWP 7.1 ->  Commons-Fileupload 1.2
iWP 7.0 ->  Commons-Fileupload 1.2
iWP 6.1 ->  Commons-Fileupload 1.1.1
iWP 6.0 ->  Commons-Fileupload 1.0
iAP:https://issue.intra-mart.jp/issues/4370
* Commons-Fileupload 1.2.2 to be a patch application target is in only 2013 Winter (8.0.6).
iWP:http://newsupport.intra-mart.jp/patch/download/patch_info.php?patch_cd=1173 (Japanese)
* Commons-FileUpload 1.2.2 to be a patch application target is in WebPlatform/AppFramework 7.2 Patch06 or later versions.
*Please make sure to replace it only when using commons-fileupload-1.2.2.jar.
If you replace it in the environment with commons-fileupload-1.2.jar, it will not operate normally.

-- Target ------------------------------------------------------------------------
iAP/Accel Pratform/All Updates
iWP/Web System Construction Platform/WebPlatform/AppFramework
----------------------------------------------------------------------------------


FAQID:377
Was this article helpful?
0 out of 0 found this helpful
Powered by Zendesk