This issue has been fixed in 2014 Summer (Honoka). (Requirement [4618])
However, there is no change in the content described in the caution.
[Condition]
This occurs when the following conditions are all satisfied.
・A distributed environment with multiple application servers.
・Specifications of all application servers are almost the same.
・All application servers execute stop processing almost at the same time.
[Cause]
If another server detects which iAP is down, the service is reelected.
If multiple servers are stopped at the same time, service reelection might be executed in parallel with the stop processing, and the application might not be stopped properly.
[Workaround]
If there are multiple application servers, stop them sequentially with a time lag.
*The time difference before the stop depends on the environment.
For example, the time changes because job execution or asynchronous processing might be running.
[Measure]
The service no longer starts for the server which has been stopped according to the requirement [4618].
https://issue.intra-mart.jp/issues/4618
■Note
This symptom is caused not only by our product (iAP) which operates in the application layer but also by the lower level layer (*1), which might cause this symptom.
Even if you apply an updated version of our product (iAP) which will be supported in the future, this symptom might not always be avoided.
(*1) For example, in the network layer, this symptom might occur due to network timeout.
-- Target --------------------------------------------------------------------
iAP/Accel Platform/All Updates
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FAQID:433
If servers are stopped at the same time in a distributed environment, services such as the job scheduler might be reelected/started in parallel with the application stop process, which might prevent normal termination.
