On some Android devices, the screen of the smartphone version is not displayed.

 
[Occurrence condition]
 Using some Android devices

[Cause]
 This is because the value of User-Agent requested when accessing from an Android device is different from the format expected by the system.
 We have confirmed that this symptom when accessing from Android 9 or later devices.

[Workaround]
 Place a setting file to correspond to the new User-Agent format.
 Please follow the steps below at IM-Juggling.

1. Select the target project and create a "plugin" folder. In addition, create a folder under it.
 The folder name is "jp.co.intra_mart.multi_device.android_chrome_8.0.0.1"

2. Create "plugin.xml" in the created folder. Copy the following to "plugin.xml"

<?xml version="1.0" encoding="utf-8"?>
<plugin>
    <extension point="jp.co.intra_mart.foundation.multi_device.client_type.matcher">
        <client-type-config id="android_chrome" version="8.0.0.1">
            <client-type-id>sp</client-type-id>
            <matcher-class>jp.co.intra_mart.system.multi_device.client_type.matcher.UserAgentMatcher</matcher-class>
            <init-param>
                <param-name>user-agent</param-name>
                <param-value>Android.*Chrome/[\\.0-9]* Mobile</param-value>
            </init-param>
        </client-type-config>
    </extension>
    <extension point="jp.co.intra_mart.foundation.multi_device.client_type.matcher">
        <client-type-config id="android_chrome_tablet" target="android_chrome" version="8.0.0.1">
            <client-type-id>sp</client-type-id>
            <matcher-class>jp.co.intra_mart.system.multi_device.client_type.matcher.UserAgentMatcher</matcher-class>
            <init-param>
                <param-name>user-agent</param-name>
                <param-value>Android.*Chrome/[\\.0-9]* (?!Mobile)</param-value>
            </init-param>
        </client-type-config>
    </extension>
</plugin>

 [Handling method]
 Please update to intra-mart Accel Platform 2019 Spring or later.

 Improve the conditions for determining whether to treat as a smartphone when accessing from an Android terminal.
 https://issue.intra-mart.jp/issues/29184


-- Target ------------------------------------------------------------------------
iAP/Accel Platform/2018 Winter and earlier updates
--------------------------------------------------------------------------------




FAQID:697
Was this article helpful?
0 out of 0 found this helpful
Powered by Zendesk