When I access intra-mart products after update, exception is output and screen moves to the session time out or error screen.

 
When I access intra-mart products after update, exception is output and screen moves to the session time-out or error screen. 
java.io.InvalidClassException: jp.co.intra_mart.foundation.portal.common.portletcontainer.driver.IntramartPortletWindowDataImpl; local class incompatible: stream classdesc serialVersionUID = XXXXXXXXXXXXXXX, local class serialVersionUID = XXXXXXXXXXXXXXX


[Condition]
Exception might occur when you access after update in the case that session information permanent is executed. 
To execute session information permanent at intra-mart Accel Platform, there are following ways. 

・In the case of setting session_store of Resin true 
・In the case of setting session information permanent with using session management module

[Cause]
This issue occurs because the class information of permanent session data and  the class information to be restored are different. 

[Handling method]
Please delete permanent session information before deploying updated application. 

・In the case of setting session_store of Resin true

       Please delete <%RESIN_HOME%>/resin-data/app-0/distcache. 

・In the case of setting session information permanent with using session management module

        Please truncate im_http_session table at database of permanent destination.

Besides, it can also be avoided by deleting cookie which is saved in the browser when you access intra-mart products for the first time after update. 

-- Target------------------------------------------------------------------------
iAP/Accel Platform/All Updates
--------------------------------------------------------------------------------


FAQID:531
Was this article helpful?
0 out of 0 found this helpful
Powered by Zendesk