[Symptom]
In the environment using IMBox, either of the following error messages is displayed.
・In [E.IWP.IMBOX.COMMON.00008] MessageColumnFamily, no value exists or any value is logically deleted. Input value [threadId:xxxxx]
・In [E.IWP.IMBOX.COMMON.00005] UserColumnFamily, no value exists or any value is logically deleted. Input value [userCd:xxxxx]
[Cause]
In Apache Cassandra data, a mismatch might occur.
[Handling Method]
The symptom might improve through execution of the following two methods.
Even through the execution of either method, the symptom might improve.
1. Repair Apache Cassandra data.
1-1. Stop all systems on intra-mart AccelPlatform.
In order to block the access to the Apache Cassandra server, stop the systems.
1-2. Confirm that all Apache Cassandra servers are running.
Start all Apache Cassandra servers if servers are not running.
In the case of one Apache Cassandra server, there is no problem if the server is in the stop state.
1-3. Execute the following command in all Apache Cassandra servers.
%CASSANDRA_HOME%/bin/nodetool repair -pr
In the case of one Apache Cassandra server, the following command executes the same process as the above command.
%CASSANDRA_HOME%/bin/nodetool repair
1-4. If the Apache Cassandra is in the stop state, start the server.
1-5. Start all systems on intra-mart AccelPlatform.
2. Execute “Data reconstruction Jobnet.”
2-1. https://www.intra-mart.jp/document/library/iap/public/imbox/imbox_specification/texts/base/federation/jobscheduler/index.html#jobnet-data-rebuild
-- Target ---------------------------------------------------------------------
iAP/Accel Platform/All Updates
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FAQID:1033