During operation on Google Chrome, the screen scrolls unnecessarily.

 
If the following operations are performed on Google Chrome, the screen may scroll unnecessarily.

   *Entering characters in autocomplete component
   *Clicking the “Show more” button in IMBox

This behavior is confirmed on the following Google Chrome version.

   * 84.0.4146.89

This phenomenon occurred because the Google Chrome upgrade changed the scrolling behavior during the element operation in focus.

Either of the following methods can prevent this phenomenon.

   1. Using the Google Chrome version in which this phenomenon does not occur
   2. Applying a hotfix to intra-mart Accel Platform

“1. Using the Google Chrome version in which this phenomenon does not occur”

We have confirmed that this phenomenon does not occur in versions prior to Google Chrome 84.


“2. Applying a hotfix to intra-mart Accel Platform”

When a hotfix is applied to intra-mart Accel Platform, it needs to be created with e Builder.
This phenomenon can be prevented by application of the user module created in the following procedure.

1. Boot IM-Juggling, open the target project, and perform “Output of static file.”

   https://www.intra-mart.jp/document/library/iap/public/setup/iap_setup_guide/texts/create_war/create_static_file.html

2. Unzip the output zip file and extract the following files.

   * ui/css/imui.css
   * ui/css/imui.min.css

3. Add the following to the end of each file.

.ui-autocomplete-input {
  overflow-anchor: none;
}

4. If you use the IMBox module, extract the following files.

   * imbox/css/imbox.css
   * imbox/css/imbox.min.css

5. Add the following to the end of each file.

#imui-container div.imbox div.imbox-timeline div.imbox-timeline-body #imbox_timeline_more button.imbox-timeline-more-button {
  overflow-anchor: none;
}
#imui-container div.imbox div.imbox-common-user-select div.imbox-common-user-box-area input.imbox-common-user-select-input {
  overflow-anchor: none;
}

6. Place the file fixed by creating the module project in the e Builder to the project.

   https://www.intra-mart.jp/document/library/ebuilder/public/e_builder_user_guide/text/common_function/index.html

   Place the fixed file to the following place of the project.
   https://www.intra-mart.jp/document/library/ebuilder/public/e_builder_user_guide/text/process/index.html# The configuration of the module project

      * src/main/public/ui/css/imui.css
      * src/main/public/ui/css/imui.min.css
      * src/main/public/imbox/css/imbox.css (When the IMBox module is used)
      * src/main/public/imbox/css/imbox.min.css (When the IMBox module is used)

   Edit module.xml and add the following dependencies.
   https://www.intra-mart.jp/document/library/ebuilder/public/e_builder_user_guide/text/process/module.html

      * id: jp.co.intra_mart.im_ui
      *Version: The version number of the UI basic module
      *The smallest version: The version number of the UI basic module
      *The largest version: The version number of the UI basic module

   *For the version number of the UI basic module, open juggling.im on the IM-Juggling, and check the version number of the “UI basic module” by clicking “intra-mart Accel Platform” on the “Base module tab” -> “Standard function” -> “Basic function.”
   

   When you use the IMBox module, add the following dependencies.

      * id: jp.co.intra_mart.imbox
      *Version: The version number of the IMBox
      *The smallest version: The version number of the IMBox
      *The largest version: The version number of the IMBox

   *For the version number of the IMBox, open juggling.im on the IM-Juggling, and check the version number of the “IMBox” by clicking “intra-mart Accel Platform” on the “Base module tab” -> “Standard function.”

5. Export the imm file and create a user module.

   https://www.intra-mart.jp/document/library/ebuilder/public/e_builder_user_guide/text/common_function/imm_export.html

*For the method of applying a use module, refer to the following URL.
   I don’t know how to apply update/patch/user module.
   https://global.intra-mart.support/hc/en-us/articles/360055835853-I-don-t-know-how-to-apply-update-patch-user-module-

This problem will be supported in the update of 2020 Summer (Zephirine) [8.0.26].

 -- Target ------------------------------------------------------------------------
iAP/Accel Platform/All Updates
 ----------------------------------------------------------------------------------

FAQID:1027
Was this article helpful?
0 out of 0 found this helpful
Powered by Zendesk