When I do not have Internet access, the IMM file export fails.

 
[Occurrence condition]
This occurs when you do not have access to the Internet.

[Cause]
Validation is performed to ensure that the module does not contain incorrect xml when exporting the imm file.
This verification requires an Internet connection. In an environment where an Internet connection is not available, the export will take longer than usual depending on the number of XML files, and the export will fail because the verification will wait until a communication timeout occurs.

[Workaround]
By adding the following settings to the .ebuilder-export.xml used when exporting the imm file, it is possible to set it so that xml format check is not performed when creating the imm file.

-------------------------------------------------------------------------------
<build>
    <plugins>
        <!-- Add - From here -->
        <plugin>
            <groupId>jp.co.intra_mart.maven</groupId>
            <artifactId>check-xml-format-plugin</artifactId>
            <version>1.0.0</version>
            <configuration>
                <execCheck>false</execCheck>
            </configuration>
        </plugin>
        <!-- Add- Up to here -->
-------------------------------------------------------------------------------

-- Target -----------------------------------------------------------------------------------------------
iAP/Accel Extensions/intra-mart e Builder for Accel Platform/All Updates
---------------------------------------------------------------------------------------------------------

FAQID:1394
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