[Occurrence condition]
If the connection validation settings are disabled (not set) and you are using Resin 4.0.67 or later
[Cause]
If an error occurred during the previous SQL execution, temporary internal connection validation will be enabled.
As a result, the verification will be performed at the next connection acquisition. However if the connection verification settings are disabled (or not set) in the settings file, the verification will be treated as a failure, and the warning log "ManagedConnectionImpl[xxx] failed database ping." will be output.
[Workaround]
This warning log is output when a connection is acquired after an error occurs, but since the connection is discarded, it does not affect the operation of the product.
As mentioned above, the cause of the log output is that the connection verification settings in the setings file are disabled (not set).
Therefore, enabling the connection verification settings can help reduce the frequency of this warning log.
* Please note that even if the validation settings are enabled, this warning log will be output if the connection is closed at the time of connection acquisition. Therefore, this warning log will not be completely suppressed.
■ intra-mart Accel Platform Settings file reference - resin-web settings Connectionon Verification Settings
https://document.intra-mart.jp/library/iap/public/configuration/im_configuration_reference/texts/resin/resin-web/index.html#%E3%82%B3%E3%83%8D%E3%82%AF%E3%82%B7%E3%83%A7%E3%83%B3%E6%A4%9C%E8%A8%BC%E8%A8%AD%E5%AE%9A
--Target-------------------------------------------------------------------------
iAP/Accel Platform/All Updates
--------------------------------------------------------------------------------
FAQID:1425
After updating Resin, the warning log "ManagedConnectionImpl[xxx] failed database ping." started to appear despite the connection validation settings being disabled.